Đăng nhập
Đăng ký
Đăng nhập bằng FB
Chủ đề mới cập nhật
Hãy đăng nhập để cùng tham gia thảo luận, chia sẽ, trao đổi các vấn đề về Wap/Web tại diễn đàn NhanhNao.Xyz
Murin Murin Icon Offline - JohnCMS
114  163
LapTrinh.Pro @ Murin • Abroths
14h33 - 26/07/2016
#1 
Như các bạn đã biết Openshift hiện tại chỉ hỗ trợ PHP5.4 và PHP5.3 và thôi, hiện tại có nhiều mã nguồn và framework yêu cầu phiên bản PHP rất cao như Laravel hay Flarum nữa. Vì vậy mình cung cấp một source code trên github dùng để cài PHP5.5 trở lên. Source này dùng trên DIY Cartridge, có các lợi ích sau:
++ (+/-)


PHP + Apache

Chỉnh sửa Do It Yourself cartridge của Openshift. Cung cấp PHP 5.5+ và cấu hình Apache đầy đủ, có thể xem ở thư mục conf.

Cài đặt nhanh






Cài đặt PHP OpenShift

1. Mở https://openshift.redhat.com/a ... y-0.1
2. Điền vào Source Code: https://github.com/ladyga14/op ... p.gitBranch/Tag phiên bản php bạn muốn sử dụng. Hiện tại hỗ trợ 3 phiên bản:
php5.5
php5.6
php7
3. Click Create Application và đợi
4. Mở website của bạn (vd: foo-bar.rhcloud.com ) và giữ cho trình duyệt mở. Trong thời gian đó bạn có thể git clone ứng dụng và bắt đầu code.
5. IMPORTANT : Trong khi ứng dụng đang build thì bạn không được git push trong thời gian đó.

TIPS

Quá trình cài đặt sẽ diễn ra trong khoảng 20-30 phút.
Mặc định nếu bạn không điền branch thì sẽ chọn phiên bản php5.6 để cài đặt
Khi chỉnh sửa conf/httpd.conf, bạn phải load lại ứng dụng, hoặc chạy ${OPENSHIFT_REPO_DIR}/.openshift/action_hooks/reload để nó hoạt động.

Phản hồi

Trong quá trình cài đặt nếu xảy ra lỗi vui lòng thông báo tại đây. Hoặc tạo một

trên github

Murin đã chỉnh sửa (4) lúc 14h41 - 26/07/2016

 Poo, RoSino18k, Thach, Ging, AngelKiZ,  thích điều này
thienteakee thienteakee Icon Offline - JohnCMS
10  41
Genko
16h16 - 28/07/2016
#7 
Murin đã nói:
Như các bạn đã biết Openshift hiện tại chỉ hỗ trợ PHP5.4 và PHP5.3 và thôi, hiện tại có nhiều mã nguồn và framework yêu cầu phiên bản PHP rất cao như Laravel hay Flarum nữa. Vì vậy mình cung cấp một s
B biết bật báo lỗi code cho ops k? Bật giúp mình phát. thấy hostinger free còn có báo lỗi, cái này ngon hơn chắc fải có chứ nhỉ

Murin Murin Icon Offline - JohnCMS
114  163
LapTrinh.Pro @ Murin • Abroths
09h28 - 29/07/2016
#8 
thienteakee đã nói:
B biết bật báo lỗi code cho ops k? Bật giúp mình phát. thấy hostinger free còn có báo lỗi, cái này ngon hơn chắc fải có chứ nhỉ
có chứ, k báo lỗi là do code chứ đâu phải do ops. bạn có thể cài các công cụ báo lỗi như tracy hay whoops để nó hiện lỗi dễ nhìn hơn
https://tracy.nette.org
http://filp.github.io/whoops/